
 

IFW V. 4.2 REPORTS 
Overview 

The Infortel for Windows report designer lets you create a variety of reports that you can print, export or e-mail. The 
reports process is initiated from the Infortel for Windows Control Center. The Reports menu displays a list of the databases 
that are available. An overview of the report generation process is illustrated below: 

 

Creating Reports 

The first step in creating a report is to select the database. To do this, follow these steps: 

1) At the Infortel for Windows Control Center, click the Reports menu. 

2) Click the database that you wish to create a report from. 

After you select a database, the next steps are to specify items that will make up the report and to define its parameters. 
These procedures are carried out at the Reports screen for the database and the Reports Parameters screen. 

Please note: IFW reports have been optimized for laser printer use. The print margins for reports in Landscape format is ½" 
right and left. Print margins for reports cannot be adjusted. Printers that require larger page margins, such as some Ink Jet 
printers, may not print the full report. 

LAYOUT OF THE REPORTS SCREENS 

The Reports screens are similar to the Database screens, except that a yellow border surrounds them. The only Reports 
screen not using the tree structure is the Account Code Reports screen.  

At the top of the Reports screen is the Menu Bar, and depending on the database is selected, the menu items will vary. 

The Button Bar is located just below the Menu Bar. The buttons available will depend on the database is accessed. For 
example, the Find button displays a Search dialog box that is found only in the Directory Reports screen. (See below) 

Making Selections for the Report 

To select which items of the selected database to include in a report, follow these steps: 

1) Double click that item in the left pane, or 

2) Highlight the item and click the  button in the Button Bar. 

Please note: you cannot select different levels. For example, you cannot select a Department and an Extension. 

To see which items have been added, highlight the top-most level in the database tree. A list of selected items will 
appear in the right pane. If you do not make any selections for a Report Pool, the system defaults to the entire database 
to be included in the report. 

ADDING MULTIPLE ITEMS 

If you wish to add multiple items, follow these steps: 

1) In the left pane, highlight the level that contains the desired item.  

2) The items in that level will appear in the right pane. 

3) If the items to be selected are sequential, highlight the first item, and while holding down the Shift key, click the last 
item. 

4) While still holding down the Shift key, select Add To Report Pool from the Edit or pop-up menus  



 

5) If the items to be selected are not sequential, click each desired item while holding down the Ctrl key. 

6) While still holding down the Ctrl key, select Add To Report Pool from the Edit or pop-up menus 

REMOVING ITEMS 

To remove all items from the Report Pool: 
• In the Edit menu, select the Clear Report Pool menu item or, click the  button.  
To remove a single item: 

1) Highlight the top-most level in the left pane, and all selected items will display in the right pane, and the  button 
becomes active. 

3) In the right pane, select an item, and click the  button. 

SAVED REPORT POOLS 

A Saved Report Pool lets you save a set of all selected items in the Reports screen to its own file. The Saved Report Pool 
file containing the selected items can then be accessed at any time when that report needs to be printed again. 

Please note: if you intend to use Pools, it is highly recommended that you provide descriptive names for your Report 
Pools to help you remember each item saved in the pool. 

• To save a Report Pool: 

1) Click File on the Menu Bar. 

2) Select the Save Report Pool menu item, and a Save Report Pool dialog box appears. 

3) Enter the name of the pool in the Report Pool Name text box, and click Save. 
• To open a saved Report Pool: 
1) Click File on the Menu Bar, and 

2) Select the Open Report Pool menu item, and an Open Report Pool dialog box appears. 

3) Select the desired Report Pool using the Report Pool drop-down list box, and click OK. 
• To delete a Report Pool: 
1) Click File on the Menu Bar. 

2) Select the Delete Report Pool menu item, and a Delete Report Pool dialog box appears. 

3) Select the desired Report Pool using the Report Pool drop-down list box, and click OK. 

SELECTING A REPORT TYPE 

After you select the items to be included in the report, click Reports from the Menu Bar of the Reports screen. Each menu 
item displayed is a type of report unique to that database, and defines the data columns that will appear in a report. 
These data columns cannot be changed. 

After you make your selections, the Report Generator becomes active, and the Report Parameters dialog box will 
appear. 

Selecting Report Parameters 

The eight tabs of the Report Parameters dialog box provide you with a great deal of flexibility to create a variety of 
reports. 

Clicking Save current settings as default lets you save settings you make on any of the tabbed screens. 

Clicking Clear default settings lets you clear all the settings you have entered on the screen tabs. The screen tab values 
are set back to the original default settings. 

The Report Type field displays the type of report selected in the Reports screen. 

The Report Subjects field displays the items selected in the Reports screen. 

DATE TAB 

The Date tab lets you choose the days you want to include in the report you are generating. Only days with processed 
data or processed and raw data can be used to create reports. Days with only raw data cannot be used until that data 
is processed. 

Within the Date tab are two different date selection tabs: 

Select Range of Dates Tab 

To use the Select Range of Dates tab, follow these steps: 

1) In the Start Date calendar, click the first date in the date range.  



 

2) In the End Date calendar, click the last date in the date range.  

3) To move through the calendar by month, click the horizontal arrows, and to move by year, click the scroll bar. 

4) You may also type the start and end dates directly into the text box below each calendar. 

Select Individual Dates Tab 

To use the Select Individual Dates tab, follow these steps: 

1) Click a particular date. 

2) To move through the calendar by month, click the horizontal arrows, and to move by year, click the scroll bar. 

TIME TAB 

Time settings pertain to data selected for inclusion in the report, not when the report runs.  

The Continuous button specifies the time for every moment within the first and last days in the range set in the Date tab. 
When Entire Day is clicked, you can set it for all day, or by clicking Other, set the start and end times. 

The Interval button applies the time feature to every day in the range set in the Date tab. You can set it for after hours, or 
customize the same start and end times for every day. Remember to use military time, and by clicking Other, set the start 
and end times for each day. 

POOLS TAB 

The Pools tab provides access to all the Report Pools created. If you are creating a report in the Trunks database and 
wish to include extension selections, click the down-pointing arrow for Directory Pools, and select a previously created 
pool name. 

Depending on the database selected, that database’s pool would not be available.  

RANGE TAB 

The Range tab lets you set parameters for a chosen Site by extension range, trunk route and member, minimum and 
maximum call cost and minimum and maximum call duration. The Extension drop-down list boxes are unavailable if you 
are in the Directory reports database, and the Trunks drop-down list boxes are unavailable if you are in the Trunks reports 
database. 

TYPES TAB 

The Types tab lets you choose the types of calls you would like to include in the reports. 

FORMAT TAB 

The Format tab lets you format your report by group, add page breaks after specified levels, or to summarize by those 
levels. Different section labeling is also available. 

Depending on which database a report is being created from, the Format tab will display options specific to that 
database. If you use Authorization Codes, you can choose to have them display in reports.  

AUTO REPORT TAB 

The Auto Report tab gives you the ability to program when a report is automatically generated. In the Next Run Time text 
box, the time the Auto Report will be run is displayed. The Next Data Start Time and Next Data End Time text boxes display 
the start and end dates of the data contained in the report. If you need to change any of these settings, these text 
boxes may be edited to force a different run of the Auto Report. 

Creating an Auto Report 

After specifying all parameters for the report, you may create a new Auto Report. You must define a relative date range 
rather than a specific date because the report is scheduled to generate at intervals rather than on specific dates. To 
create a new Auto Report, follow these steps: 

1) Select the Auto Report tab. 

2) Click Create New Auto Report, and enter the name of the Auto Report in the Auto Report Name list box. 

3) Check the Activate automatic reporting box.  

4) In the Report Schedule section, set the time you want the report to automatically generate. Reports generate at 
12:01 AM for weekly and monthly report schedules. Depending on which selections are made in the Report Schedule 
section, various options will be available in the Run Weekly on Day section. 

5) The Date Range section is for specifying what dates to include in the report. 

6) Click the Save button. 

This Auto Report configuration can now be accessed for future use. 



 

To load an existing Auto Report, follow these steps: 

1) Select the Auto Report tab, and click the Load Existing Auto Report button. 

2) Click the down arrow for the Auto Report Name drop-down list box, and select the desired Auto Report. 

Auto Report Maintenance 

To edit or delete an Auto Report, follow these steps: 

1) Select the Auto Report tab, and click the Load Existing Auto Report button. 

2) Select the name of the Report from the Auto Report Name drop-down list box. 

3) To update, make any changes you wish and click the OK button. 

4) If you want to delete the Report, click the Remove button. 

To de-activate an Auto Report, follow these steps: 

1) Select the Auto Report tab. 

2) At the Auto Report Name drop-down list box, select the name of the Auto Report. 

3) Click the Activate Automatic Reporting box to remove the checkmark. 

4) Click the Save button. 

Please note: this operation does not delete the Auto Report, it merely de-activates it. 

DESTINATION TAB 

The Destination tab has three tabs with each discussed below. 

Files Tab 

You can specify the report’s file name to include a date/time format, a file format, and a file extension. 

The Files tab lets you save the report to a file and specify the format of the output. To do this, follow these steps: 

1) Click the Add button to display a Report Generator dialog box. 

2) Click the  button, and a directory dialog box will appear. Here, specify a file path for the report. What you enter 
into the File Name text box will become the first part of the report’s file name. 

3) Clicking on the File Name Date/Time Format down arrow displays a list box where you can designate a format for 
date and time. 

The format selected from this list box will be the second part of the report’s file name. 

4) To choose the format of the file, (for example, RTF, Lotus, Excel, etc.) click the Report File Format list box. 

The selection chosen from this list box will determine how the report file will be formatted, as well as the report’s file 
name extension. 

If you select ODBC (Open Data Base Connection), then the text boxes for this format become active. 

5) Click the OK button, and the file name will appear in the File tab. 

6) To delete the file name, at the File tab, highlight the name, and click Remove. 

7) To edit the format of the file, at the File tab, highlight the name, and click the Edit button, and the Report Generator 
dialog box will appear. 

Depending on the recipients’ requirements, you have the ability to generate a different version of the same report with 
each version given a unique file name and characteristics.  

Printers Tab 

The Printers tab lets you print to any available printer. After selecting the Printers tab, follow these steps: 

1) To specify a printer, click Add, and the Report Generator dialog box will appear. 

2) Choose the printer by clicking on the Printer drop-down list box, and enter any other printing specifications. 

3) Click the OK button, and the file name will appear in the Printers tab. 

4) To delete the printer name, at the Printers tab, highlight the name, and click Remove. 

5) To edit the format of the file, at the Printers tab, highlight the name, and click the Edit button, and the Report 
Generator dialog box will appear. 

Email Tab 

Please note: you must have a compliant e-mail client installed on the processing PC to use this feature.  



 

Using the Email tab, you have the ability to e-mail your report to a 32-bit MAPI compliant e-mail system. Microsoft 
Outlook 97, for example, fits this requirement. If you use some other e-mail system, contact your System Administrator. 

If you wish to e-mail reports, follow these steps: 

1) Click Add, and in the screen that displays, in the Recipient Email Address text box, enter the address of the recipient. 

2) Enter the subject of the transmission in the Email subject text box. 

3) Give the report a name in the Name for attached Report file text box. What you enter into the text box will become 
the first part of the report’s file name. 

4) Clicking on the File Name Date/Time Format down arrow displays a list box where you can designate a format for 
date and time. 
The format selected from this list box will be the second part of the report’s file name. 

5) To choose the format of the file, click the Report File Format drop-down list box. 

The selection chosen from this list box will determine how the report file will be formatted, as well as the report’s file 
name extension. 

6) Enter the Sender Information in the appropriate text boxes. 

7) Click the OK button, and the file name will appear in the Email tab. 

8) To delete the file name, at the Email tab, highlight the name, and click Remove. 

9) To edit the format of the file, at the Email tab, highlight the name, and click the Edit button, and the Report 
Generator dialog box will appear. 

Generating the Report 

After all the parameters have been set, at the Report Parameters screen, click the OK button, and the report will be 
generated, and display on the screen. When it first appears, it needs to be maximized.  

Viewing Previously Created Reports 

The Report Viewer option lets you view any previously created and saved report. To do this, you must first save it in the 
Report Parameters screen (Destination - File tab), where it must be saved with a .CRF extension. The Report Viewer is not 
able to display any report with an extension other than .CRF.  

To access previously created reports, follow these steps: 

1) Click the Start button on the Taskbar, and select the Program menu item. 

2) From the Infortel for Windows menu item, select Report Viewer, and an Open directory dialog box will appear. 

3) Double-click the desired report. 

Database Listings 
In addition to detailed reports, each database provides a means to generate a quick listing of its contents. To obtain a 
listing of a database, follow these steps: 

1) At the Infortel for Windows Control Center, select the database from the Reports menu. 

2) When the Reports screen appears, click the File menu, and select the desired menu item. 

Searching the Directory Reports Screen 
By using the Find utility in the Directory Reports screen, you are able to both search and mark selected search results to 
be added to a report pool. To do a search, follow these steps: 

1) From the IFW Control Center, select Reports and select Directory. 

2) At the Directory Reports screen, click the  button, or 

4) From the Edit menu, select the Find menu item, and a Search organization tree dialog box will appear. 

5) Type the department, person’s name or extension in the Org (last) name or extension text box.  

6) Click the Search button, and your results will be displayed in the grid. 

7) To add a name or names to the report pool, double click on each line in the grid (a pound sign (#) will appear), and 
click the Add to Report Pool button. 

Please note: you are only allowed to select multiple items if they are on the same organizational level. For example, 
you may select more than one extension, more than one department, etc, but you may not select an extension and 
department together. 

8) The Search organization tree dialog box will close, and in the left pane, the system will immediately jump to each 
selected search string and mark it with a check mark to indicate that it’s been added to the report pool. 


