
IFW QUICK REFERENCE GUIDE:  DATA MANAGER V. 4.2 
The call detail record (CDR) collected varies with the phone system you have, but it basically consists of a string 
of ASCII characters. This ASCII data is stored in RAM in the buffer box until it is collected and processed.  All raw 
data collected goes into a temporary ASCII file on your hard drive. Data Manager then formats this data into 
meaningful information for your database, according to the CDR format that you specified when installing the 
system.  Once the raw data is placed in their proper fields, they can, for example, be accessed by the 
Reporting module, or used in the costing process.  

Also, the Status and Alarms tabs keep you apprised of all IFW functions and processes that run in the 
background.  Finally, Data Manager lets you specify which type of data (databases and processed data, raw 
data, or reports) to back up, where to back it up, and when it is backed up. 

Data Manager runs only on an IFW Headquarters PC, and is installed in the Startup group for Windows.  
Therefore, it will start automatically whenever your PC starts.  To start Data Manager manually: 

1) Click on the Start button on the taskbar, and point to Programs. 

2) Point to the IFW program group, and select Restart Data Manager. 
Using either method, a Data Manager icon will appear in the system tray.  Double click on it, and the Data 
Manager screen will appear. 

Status Tab 

When the Status tab is selected, Data Manager displays information about data maintenance programs and 
their progress, and other functions. 

Alarms Tab 

The Alarms tab displays system alarm messages and other comments or warnings.  These messages are 
intended to alert a system administrator to unusual conditions, such as: 
• Calls of excessive duration or cost, 
• Malfunctioning trunks, 
• Attempted toll fraud, 
• Excessive international calling, 
• Maintenance modem access, or 
• Equipment malfunctions. 
Any alarm situations that are detected and displayed in this screen can also automatically trigger a pager to 
alert the appropriate personnel. 

To clear the displayed alarms, select the Clear Alarm Display menu item located in the Tools menu. 

File Menu 

The File menu contains the following two items: 
• Manage/view logs  
• Shut down Data Manager  

MANAGE/VIEW LOGS 

The Manage/ View Logs function lets you view the various system logs that were created by IFW.  These logs 
can be helpful for diagnosing potential system problems.    

The left side of the Manage/View Logs screen contains various IFW functions displayed in a tree-like structure.  
When a log file is first created, a folder for that file will be created.  When a plus sign is clicked, the selected 
level expands to reveal dates that the file was created. 

On the right-hand side, the three option buttons let you: 
• View a log containing both error and status and warning messages generated by various system functions, 
• View a log containing only error messages, or 
• View a log containing only the status and warning messages generated by system functions. 
To use the Log Viewer, follow these steps: 

3) Click the File menu and select Manage/ View Logs. 

4) Click a plus sign in the function tree, and select the desired date. 

5) Click one of the option buttons on the right-hand side of the screen. 

6) Click the View Logs button, and the log file will display in a text editor such as Microsoft Notepad. 



SHUT DOWN DATA MANAGER 

Selecting this menu item closes Data Manager, and removes the icon from the system tray. 

WARNING:  You will not process calls if you shut down Data Manager. 

Processing Menu 

The Processing menu contains the following items: 
• Pause Data Manager  
• Continue Data Manager  
• Reprocess Raw File  
• Re-cost Call Records  
• Debug Mode  

PAUSE DATA MANAGER 

If you need to interrupt the processing of data in order to change the way data is processed, selecting this 
menu item temporarily deactivates operation of Data Manager. 

Please Note: pausing Data Manager has no effect on the actual collection of call records.  It only pauses the 
processing of the collected call records. 

CONTINUE DATA MANAGER 

Selecting this menu item resumes operation of Data Manager.  Be sure to do this after pausing Data Manager. 

REPROCESS RAW FILE 

Raw call records are call records in the original format received from the PBX.  IFW stores raw call records for a 
period defined by the user at the Define Purge Schedule dialog. 

In certain cases, you may wish to reprocess the raw call records.  In this case, the Reprocess function performs 
the following: 
• Call records for the dates specified are purged from the call storage database 
• Calls are processed and priced 
• Calls are stored in the call storage database. 
To use this function, follow these steps: 

1) At Data Manager, click the Processing menu, select Reprocess Raw File, and the Select One Or More Files 
dialog box will appear. 

2) Select the desired file(s). 
• To select more than one sequential file, highlight the first file in the series by clicking on it, and while 

holding down the Shift key, click the last file in the series. 
• If the files are not sequential, select each file while holding down the Ctrl key. 

3) Click the OK button. 

Only when you select a file(s), does the OK button become active. 

RE-COST CALL RECORDS 

The Re-cost Call Records function will re-calculate the call price for all records selected.  You would typically 
use this function to re-price already processed calls when making changes to the pricing setup of your system. 

To use this function, follow these steps: 

1) At Data Manager click the Processing menu, select Re-cost Call Records, and the Enter Date Range to 
Continue dialog box will appear. 

2) From the Site drop-down list box, select the site for which you want to re-cost data. 

3) From the Facility list box, select the facility for which you want to re-cost data. 

4) To define the date or range of dates for the operation: 
• Specify a beginning date by clicking the button beside the Re-cost Data From text box and select a 

date from the calendar that appears.  At the calendar, click on a date, or use the arrows to change 
the date by month and scroll bar to change the year. 

• Specify an end date by clicking the button beside the Through text box and select a date from the 
calendar that appears. At the calendar, you may click on a date, or use the arrows to change the 
date by month and scroll bar to change the year. 

5) Click the OK button.  The progress of the re-costing is displayed in the Status tab screen.  

Only after specifying the site and dates, does OK become active. 



DEBUG MODE 

The Debug Mode function is typically used by ISI Technical Support personnel to diagnose problems with your 
system.  It provides two reports that detail exactly how the IFW systems parsed and priced call records. 

When the Debug Mode menu item is selected, two reports are generated and Microsoft Notepad is opened 
displaying those reports.  

A check mark will appear next to Debug mode when it is selected. 

Tools Menu 

The Tools menu contains the following items: 
• Set Backup Parameters  
• Backup Data Now  
• Restore Data  
• Purge Data Now  
• Repair and Compact Databases 
• Refresh All Statistical Data  
• Clear Alarm Display  

SET BACKUP PARAMETERS 

The Set Backup Parameters menu item lets you specify which type of data (databases and processed data, 
raw data, or reports) to back up, where to back it up, and when it is automatically backed up. 

When this is selected, the Define Automatic Back Up dialog box appears. 

With this dialog box, you can back up data to a tape drive or a hard drive. 

Please note:  If Tape is selected, you can only back up Processed data to a tape drive with the other types of 
data backed up to a hard drive.  If Disk is selected, all four types of data are backed up to a hard drive. 

The following explains how to set up an automatic backup: 

1) Specify if the data is to be backed up to disk or tape by clicking one of the option buttons at the top of 
dialog box. 

2) Along the left-hand side of the dialog box, click the check boxes to select the type of data to be backed 
up. 

3) In the adjoining text boxes, type in where to place the back-up file, and what to name it.  Click the button 
next to each text box to open a Directory dialog box to browse through folders to a destination. 

4) Enter the time the data is to be automatically backed up in the text box at the bottom of the screen.  Be 
sure to specify AM or PM. 

5) If Tape is selected, enter the tape drive number in the text box, and follow steps 2 – 4. 

Please note:  when doing a tape backup, make sure that a tape has been inserted into the tape drive for the 
scheduled backup. 

After all specifications have been entered, click the OK button to close the dialog box and save them, or the 
Cancel button to close the dialog box without saving the specifications.  

BACKUP DATA NOW 

When the Backup Data Now item is selected, Data Manager will immediately back up the type of data to the 
destination specified in the Define Backup Parameters dialog box. 

The progress of the backup is displayed in the Status tab screen. 

Please note that data will still backup automatically based on the time set in the Define Backup Parameters 
dialog box. 

RESTORE DATA 

By selecting the Restore Data menu item, the Administrator can easily retrieve files that were previously backed 
up. 

To use the this function, follow these steps: 

1) Shut down all other IFW programs. 

2) At Data Manager, click the Tools menu, and select Restore Data. 

3) An IFW Restore Utility dialog box will appear.  This box contains four option buttons that let you select the 
type of data you want to restore. 

4) Select a type of data and click the Restore button. 



• If Processed Data is selected, the subsequent dialog box will let you specify if the restore is from a Disk 
or Tape.   

5) Another dialog box will appear letting you specify the path of the file. 
• If Tape is selected, enter the tape-drive number in the text box. 

6) Click the Start Restore button, and Data Manager will restore all tables into that directory.  A screen will 
inform you the restore was successful. 

7) Click OK, and the IFW Restore Utility dialog box will appear.  Here, you may select another type of data to 
back up, or exit the Restore utility. 

8) If you click the Close button, a message box will display telling you that Data Manager will shutdown and 
may be restarted by selecting it from the Start menu or by rebooting your PC. 

You cannot perform a selective backup.  You would use this option in the event of system failure, where the 
database tables would have to be completely restored. 

WARNING:  Restoring data completely over writes your existing call accounting data.  Do not restore old data 
over a running system unless you already backed up the current system under a different backup file name! 

PURGE DATA NOW 

Using the Purge Data Now utility, you can purge a specified type or types of data for a single date or a range 
of dates for a given site. 

To access this utility: 

1) At Data Manager click the Tools menu, select Purge Data Now and the Purge Data Parameters dialog box 
will appear. 

2) From the Site drop-down list box, select the site for which you want to purge CDR. 

3) To define the date or range of dates for the purge: 
• Specify a beginning date by clicking the calendar button beside the Purge Data From text box and 

select a date from the calendar that appears.  At the calendar, click on a date, or use the arrows to 
change the date by month and scroll bar to change the year. 

• Specify an end date by clicking the calendar button beside the Through text box and select a date 
from the calendar that appears. At the calendar, click on a date, or use the arrows to change the 
date by month and scroll bar to change the year. 

4) From the Type of Data to Purge section, select the type(s) of data you wished purged by clicking the 
appropriate check box(es). 

5) Click the OK button to begin the purge, and the progress of the purge is displayed in the Status tab screen. 
• Only after specifying the site, type of data, and date, does the OK button become active. 

REPAIR AND COMPACT DATABASES 

When this menu item is selected, Data Manager compresses the database files, writes each to a temporary file, 
and then renames each file to its original name. 

This utility is scheduled to run automatically every three days.  However, if your data has become corrupt, you 
may select this menu item at any time. 

The progress of the operation is displayed in the Status tab screen. 

REFRESH ALL STATISTICAL DATA 

Selecting this menu item re-draws the histogram displayed in the IFW Control Center according to the option 
set in the Graph Values by Section in the Set Monitor Options dialog box.  To use this function, follow these 
steps: 

1) At the IFW Control Center, click the Monitors menu, and select the Clear Statistics menu item. 

2) Open up Data Manager, click the Tools menu, and select Refresh All Statistical Data.  Service will pause, 
and the progress of the operation will display in the Status screen. 

3) When Data Manager finishes processing, move to the IFW Control Center. 
4) There, click the Monitors menu, select Statistics Options, and choose a new interval in the Graph Values by 

Section. 

CLEAR ALARM DISPLAY 

Selecting this menu item removes the alarm messages displayed in the Alarms tab screen. It does not clear the 
actual alarm records stored in the database.  To clear the actual alarm records, use the manual purge function 
as described in Purge data now. 
 


