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The call detail record (CDR) collected varies with the phone system you have, but it basically 
consists of a string of ASCII characters. This ASCII data is stored in RAM or other storage medium 
until it is collected and processed. All raw data collected goes into a temporary ASCII file on your hard 
drive. Next, DataManager then formats this data into meaningful information for your database, 
according to the CDR format that you specified when installing the system. Once the raw data is 
placed in their proper fields, they can, for example, be accessed by the Reporting module, or used in 
the costing process.  

Also, the Status and Alarms tabs keep you apprised of all call accounting functions and processes 
that run in the background. Finally, DataManager lets you specify which type of data (databases and 
processed data, raw data, or reports) to back up, where to back it up, and when it is backed up. 

DataManager runs only on a Headquarters PC, and is installed in the Startup group for Windows. 
Therefore, it will start automatically whenever your PC starts. To start DataManager manually: 

1. Click on the Start button on the taskbar, and point to Programs. 

2. Point to the software’s program group, and select Restart DataManager. 

Using either method, a DataManager icon  will appear in the system tray. Double click on it, and the 
DataManager screen will appear. 

STATUS TAB 

When the Status tab is selected, DataManager displays information about data maintenance 
programs and their progress, and other functions. 

ALARMS TAB 

The Alarms tab displays system alarm messages and other comments or warnings. These messages 
are intended to alert a system administrator to unusual conditions, such as: 

¾ Calls of excessive duration or cost, 

¾ Malfunctioning trunks, 

¾ Attempted toll fraud, 

¾ Excessive international calling, 

¾ Maintenance modem access, or 

¾ Equipment malfunctions. 

Any alarm situations that are detected and displayed in this screen can also automatically trigger a 
pager to alert the appropriate personnel. 

To clear the displayed alarms, select the Clear Alarm Display menu item located in the Tools menu. 

SHOW CALLS TAB 

Note: Using this tab slows down processing time as each record is displayed. 

When the Show Calls tab is selected, DataManager displays calls as they are being processed. 

Note: The Show Calls tab only displays if it is set in the DataManager .ini file. 
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FILE MENU 

The File menu contains the following two items: 

¾ Manage/view logs  

¾ Shut down DataManager  

Manage/View Logs 
The Manage/ View Logs function lets you view the various system logs that were created by the call 
accounting software. These logs can be helpful for diagnosing potential system problems.   

The left side of the Manage/View Logs screen contains various call accounting software functions 
displayed in a tree-like structure. When a log file is created, a folder for that file will be created. When 
a plus sign is clicked, the selected level expands to reveal dates that the file was created. 

On the right-hand side, the three option buttons let you: 

¾ View a log containing both error and status and warning messages generated by various 
system functions, 

¾ View a log containing only error messages, or 

¾ View a log containing only the status and warning messages generated by system functions. 

To use the Log Viewer, follow these steps: 

1. Click the File menu and select Manage/ View Logs. 

2. Click a plus sign in the function tree, and select the desired date. 

3. Click one of the option buttons on the right-hand side of the screen. 

4. Click the View Logs button, and the log file will display in a text editor such as Microsoft 
Notepad. 

Shut Down DataManager 
Selecting this menu item closes DataManager, and removes the icon from the system tray. 

WARNING:  You will not process calls if you shut down DataManager. 

PROCESSING MENU 

The Processing menu contains the following items: 

¾ Pause DataManager  

¾ Continue DataManager  

¾ Reprocess Raw File  

¾ Re-cost Call Records  

¾ Debug Mode  

Pause DataManager 
If you need to interrupt the processing of data in order to change the way data is processed, selecting 
this menu item temporarily deactivates operation of DataManager. 

Note: Pausing DataManager has no effect on the actual collection of call records. It only 
pauses the processing of the collected call records. 

Continue DataManager 
Selecting this menu item resumes operation of DataManager. Be sure to do this after pausing 
DataManager. 
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Reprocess Raw File 
Raw call records are call records in the original format received from the PBX. The software stores raw 
call records for a period defined by the user at the Define Purge Schedule dialog. 

In certain cases, you may wish to reprocess the raw call records. In this case, the Reprocess function 
performs the following: 

¾ Call records for the dates specified are purged from the call storage database 

¾ Calls are processed and priced 

¾ Calls are stored in the call storage database. 

To use this function, follow these steps: 

1. At DataManager, click the Processing menu, select Reprocess Raw File, and the Select 
One Or More Files dialog box will appear. 

2. Select the desired file(s). 

• 

• 

• 

• 

To select more than one sequential file, highlight the first file in the series by clicking on 
it, and while holding down the Shift key, click the last file in the series. 

If the files are not sequential, select each file while holding down the Ctrl key. 

3. Click the OK button. 

Only when you select a file(s), does the OK button become active. 

Re-cost Call Records 
The Re-cost Call Records function will re-calculate the call price for all records selected. You would 
typically use this function to re-price already processed calls when making changes to the pricing 
setup of your system. 

To use this function, follow these steps: 

1. At DataManager click the Processing menu, select Re-cost Call Records, and the Enter 
Date Range to Continue dialog box will appear. 

2. From the Data Source list box, select the data source for which you want to re-cost data. 

3. From the Facility list box, select the facility for which you want to re-cost data. 

4. To define the date or range of dates for the operation: 

Specify a beginning date by clicking the button beside the Re-cost Data From text box 
and select a date from the calendar that appears. At the calendar, click on a date, or use 
the arrows to change the date by month and scroll bar to change the year. 

Specify an end date by clicking the button beside the Through text box and select a date 
from the calendar that appears. At the calendar, you may click on a date, or use the 
arrows to change the date by month and scroll bar to change the year. 

5. Click the OK button. The progress of the re-costing is displayed in the Status tab screen.  

Only after specifying the data source and dates, does OK become active. 

Debug Mode 
The Debug Mode function is typically used by Technical Support personnel to diagnose problems with 
your system. It provides two reports that detail exactly how the call accounting software parsed and 
priced call records. 

When the Debug Mode menu item is selected, two reports are generated and Microsoft Notepad is 
opened displaying those reports.  

A check mark will appear next to Debug mode when it is selected. 
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TOOLS MENU 

The Tools menu contains the following items: 

¾ Set Backup Parameters  

¾ Backup Data Now  

¾ Restore Data  

¾ Delete Duplicates From Processed Data  

¾ Purge Data Now  

¾ Refresh All Statistical Data  

¾ Clear Alarm Display  

Set Backup Parameters 
The Set Backup Parameters menu item lets you specify which type of data (databases and 
processed data, raw data, or reports) to back up, where to back it up, and when it is automatically 
backed up. 

When this is selected, the Define Automatic Back Up dialog box appears. 

With this dialog box, you can back up data to a tape drive or a hard drive. 

Note:  If Tape is selected, you can only back up Processed data to a tape drive with the 
other types of data backed up to a hard drive. If Disk is selected, all three types of data are 
backed up to a hard drive. 

The following explains how to set up an automatic backup: 

1. Specify if the data is to be backed up to disk or tape by clicking one of the option buttons at 
the top of the Define Automatic Back Up dialog box. 

2. Along the left-hand side of the Define Automatic Back Up dialog box, click the check boxes 
to select the type of data to be backed up. 

3. In the adjoining text boxes, type in where to place the back-up file, and what to name it. 
Click the button next to each text box to open a Directory dialog box to browse through 
folders to a destination. 

4. Enter the time the data is to be automatically backed up in the text box at the bottom of the 
screen. Be sure to specify AM or PM. 

5. If Tape is selected, enter the tape drive number in the text box, and follow steps 2 – 4. 

Note: When doing a tape backup, make sure that a tape has been inserted into the tape 
drive for the scheduled backup. 

After all specifications have been entered, click the OK button to close the dialog box and save them, 
or the Cancel button to close the dialog box without saving the specifications.  

Note: If you have an Infortel Select Enterprise system, it is recommended that you back up 
only Miscellaneous and Raw data using SQL Server’s Enterprise Manager to back up the SQL 
database. 

Backup Data Now 
When the Backup Data Now item is selected, DataManager will immediately back up the type of data 
to the destination specified in the Define Backup Parameters dialog box. 

The progress of the backup is displayed in the Status tab screen. 

Note: Data will still backup automatically based on the time set in the Define Backup 
Parameters dialog box. 
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Restore Data 
By selecting the Restore Data menu item, the Administrator can easily retrieve files that were 
previously backed up. 

To use the this function, follow these steps: 

1. Shut down all other call accounting software. 

2. At DataManager, click the Tools menu, and select Restore Data. 

3. A Restore Utility dialog box will appear. This box contains four option buttons that let you 
select the type of data you want to restore. 

4. Select a type of data and click the Restore button. 

• 

• 

If Processed Data is selected, the subsequent dialog box will let you specify if the 
restore is from a Disk or Tape.  

5. Another dialog box will appear letting you specify the path of the file. 

If Tape is selected, enter the tape-drive number in the text box. 

6. Click the Start Restore button, and DataManager will restore all tables into that directory. A 
screen will inform you the restore was successful. 

7. Click OK, and the Restore Utility dialog box will appear. Here, you may select another type 
of data to back up, or exit the Restore utility. 

8. If you click the Close button, a message box will display telling you that DataManager will 
shutdown and may be restarted by selecting it from the Start menu or by rebooting your PC. 

You cannot perform a selective backup. You would use this option in the event of system failure, 
where the database tables would have to be completely restored. 

WARNING:  Restoring data completely over writes your existing call accounting data. 
Do not restore old data over a running system unless you already backed up the current 
system under a different backup file name! 

Delete Duplicates From Processed Data 
Select this menu item to run the de-duplication routine. This will remove duplicate call records that 
have been processed from the database.  

Purge Data Now 
Using the Purge Data Now utility, you can purge a specified type or types of data for a single date or a 
range of dates for a given data source. To access this utility: 

1. At DataManager click the Tools menu, select Purge Data Now and the Purge Data 
Parameters dialog box will appear. 

2. From the Data Source list box, select the data source for which you want to purge CDR. 

3. To define the date or range of dates for the purge: 

• 

• 

• 

Specify a beginning date by clicking the calendar button beside the Purge Data From 
text box and select a date from the calendar that appears. At the calendar, click on a 
date, or use the arrows to change the date by month and scroll bar to change the year. 

Specify an end date by clicking the calendar button beside the Through text box and 
select a date from the calendar that appears. At the calendar, click on a date, or use the 
arrows to change the date by month and scroll bar to change the year. 

4. From the Type of Data to Purge section, select the type(s) of data you wished purged by 
clicking the appropriate check box(es). 

5. Click the OK button to begin the purge, and the progress of the purge is displayed in the 
Status tab screen. 

Only after specifying the data source, type of data, and date, does the OK button become 
active. 

Infortel Select – Version 6.1  5  Part Number – 905-011012 



Quick Reference Guide: DataManager  ISI, Inc.  

Refresh All Statistical Data 
Selecting this menu item re-draws the histogram displayed in the Control Center according to the 
option set in the Graph Values by section in the Set Monitor Options dialog box. To use this 
function, follow these steps: 

1. At the Control Center, click the Monitors menu, and select Clear Statistics. 

2. Open up DataManager, click the Tools menu, and select Refresh All Statistical Data. 
Service will pause, and the progress of the operation will display in the Status screen. 

3. When DataManager finishes processing, move to the Control Center. 

4. There, click the Monitors menu, select Statistics Options, and choose a new interval in the 
Graph Values by section. 

Clear alarm display 
Selecting this menu item removes the alarm messages displayed in the Alarms tab screen. It does 
not clear the actual alarm records stored in the database. To clear the actual alarm records, use the 
manual purge function as described in Purge data now. 
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