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Quick Reference Guide: Directory Database for the Web 
You must add the levels of the Directory database in order below the Organization symbol . 

Note for the optional Facilities Management module: 

If you purchased the Facilities Management module, you should be aware of the relationship 
between the Directory database and that module. This relationship is provided in Notes 
found in each relevant section. 

ADDING AN ORGANIZATION LEVEL TO THE DIRECTORY DATABASE 

Adding the highest organization level is the first step in creating the Directory database. Adding the 
lower levels (apart from the user level) involves the same steps with the exception being that you 
highlight a different organization symbol. 

There are two routes to adding an organization level: 

 Using the Add menu item in the Edit menu 

 Clicking the  button 

These two methods are slightly different and are explained below. 

 After highlighting a level, from the Edit menu, select the Add menu item to add any level 
above, or immediately below the selected level. An Add “level” dialog box will appear, and 
proceed with Step 1 below. 

 After highlighting a level, click the  button to add a level immediately below the selected 
level. An Add “level” dialog box will appear, and proceed with Step 1 below. 

1. At the Add “level” dialog box, enter a unique 30 character alphanumeric level name in the 
Name text box. 

2. In the Code text box, enter a unique 20 character alphanumeric code for this level. 

3. From the Language list box, select the language that reports will appear in for everyone in 
the organizational level. 

Note: The Language list box may not appear in your system, and not all reports can be 
printed in other languages. Enter the optional name and address information that will 
appear in a billing report. 

4. Click the Save & Close button. 

-or- 

5. Click the Save & Continue button if you are adding more than one name at this level, and 
the dialog box will remain on the screen. When finished, click the Save & Close button to 
close the dialog box. 
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ADDING A USER TO THE DIRECTORY DATABASE 

Note for the optional Facilities Management module: 

When a new person is added from a service request in Facilities Management, that person's 
record is marked as such. The Directory Administrator can then access a listing from the 
Directory database and use the listing to complete/edit that person's record. 

Whenever a user is added to the Directory database, that user is considered “active” until their status 
is changed to “inactive.” To add a person, follow these steps: 

1. At the main Directory Database screen, expand the level you want to add a person to until 
the  symbol appears. Click on the  symbol. 

2. Click the  button, or from the Edit menu, choose Add Person from the submenu. With 
either method, the Add Person screen will appear. 

3. The Add Person screen contains five tabs for adding information on a person, and above the 
tabs is a set of buttons. 

Move: When you click this button, a screen will appear to let you move the current user to another 
organization level. See the section below for information on the Move feature. 

Delete: This button deletes the current user from the database. See below for more information on 
deleting a user. 

Save: Click this button to save the information while keeping the screen displayed. 

Save & Close: Click this button to save the information and close the screen. 

Close: Click this button to close the screen without saving any information. 

General Tab 

Note for the optional Facilities Management module: 

If you purchased the optional Facilities Management module, creating a warehouse is very 
similar to adding a person. However, when creating a warehouse, you must click the Flag 
This Person as an Inventory Warehouse check box. 

The General tab is used for entering basic information for a user as well as indicating if the user will 
or will not receive automatically generated reports, specifying a Billing Class for the user, and 
assigning the user a security level. 

Last Name: Enter the user's last name in this text box. This is a required field. 

First Name: Enter the user's first name in this text box. This is optional. 

Title: Enter the user's title in this text box. This is optional. 

E-mail: Enter the user's e-mail address in this text box. This is optional. 

Note for the optional Facilities Management module: 

If you purchased the optional Facilities Management module, the email address you enter 
here will appear in Facilities Management for a technician. Any changes made in this text box 
will update Facilities Management as well. Conversely, if an email address for a technician is 
updated in Facilities Management, the Directory database will be updated. 
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Language: Select the language that certain reports will appear in for the current user. 

Note: The Language list box may not appear in your system, and not all reports can be 
printed in other languages.  

Exclude this person from auto-mail: Select this check box if you do not want this user to 
automatically receive reports via e-mail. 

Billing Class: Assign the user a Billing Class (default is Billing Class 1) from this list box. This 
selection will determine which Billing Descriptions are used to price the user's calls. 

Home Site List Box: Select the site where the user is physically located from the Home Site list box. 
If the number of home sites exceeds the maximum number defined at the Misc. System Options 1 
screen during installation, then a Find Word(s) text box and Word Search button will appear. 
There, perform a search for the data source, and the results will appear in the Home Site list box.  

Find Word(s): Enter your search string in this text box. You don't have to enter an entire word, just 
a fragment. After entering a search string, Click the adjoining Word Search button, and the search 
results will include all values containing your search string. 

For example, if you enter a search string of "at", your results will include the following: cathode, flat 
screen, gateway. 

Word Search Button: Click this button to initiate the search. The results will display in the Home 
Site list box. 

Note: The Home Site Search text box and Word Search button will appear only if the 
number of home sites exceeds the maximum defined at the Misc. System Options 1 screen 
during installation. 

Directory Import Key: The Directory Import Key is used when importing new directory information. 
Additionally, it can be used to assign multiple extensions to the same user, support name changes, 
and lets you automate moves and deletions. (Optional) 

Code: In this text box, enter a unique code that will be used when the user's information is exported 
to a time and billing or accounting system. (Optional) 

Security Setting: Clicking this button opens the Directory Security screen. The Directory Security 
screen is used to control: 

 Who can enter the system 

 Which components of the system a user can access 

 Which data sources a user can access 

See below for more information on the Directory Security Screen. 

Flag this person as an inventory “warehouse”: Click this check box to specify that the current 
record is a warehouse. 

Note for the optional Facilities Management module: 

This check box appears only if you purchased the optional Facilities Management module. 

 When clicked, the following will apply: 

 A warehouse cannot have any objects attached to it 

 A warehouse cannot have any fixed or one time charges attached to it 

 A warehouse can have a billing address assigned to it in the Billing Address tab in order to 
create shipping lists 
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 A warehouse can have phone numbers assigned to it at the Other Numbers tab 

 The check box cannot be turned off if there is inventory in the warehouse 

 The warehouse cannot be deleted if there is inventory in the warehouse 

Room number: Type a valid room number in this text box. This text box appears only if you 
purchased the optional Hospitality module. 

Objects Tab 

Using the Objects tab, extensions, authorization codes, and trunk facilities (these types of data are 
referred to as “objects”), are added, maintained, and displayed in a table for each user. 

Note for the optional Facilities Management module: 

If you purchased the optional Facilities Management module, a warehouse cannot have any 
objects attached to it  

It is important to keep in mind that an extension can be: 

 An actual extension 

 A credit card number or a portion of a credit card number 

 A cell phone number 

EXTENSIONS 

An extension can be the actual extension, a credit card number, or a cell phone number assigned to a 
user. 

If the user has a reporting extension, then that will be displayed instead of the user's raw extension. 

 A reporting extension is an extension that shows up in a report. It could be the actual 
extension, the last four digits of a credit card number, or a portion of a cell phone number. 

 A raw extension is an extension as it comes in from the CDR. 

Note: Once you enter an extension and click the Add New button, you cannot change that 
extension. If you need to change it, you must delete that extension and add a new one. 

Adding an Extension 

Follow these steps to add an extension for a user: 

1. In the Extension column, enter the extension as it appears in the CDR. 

2. From the Data Source list box, select the data source of the extension. Depending on the 
number of data sources defined during the installation process, one of the following will apply 
for the Data Source column: 

 If the number of data sources is less than the maximum number defined during 
installation, a Data Source list box will be displayed. From this list box, select a data 
source for each object for the current user. 

 If the number of data sources exceeds the maximum number defined during installation, 
then a Look Up button will appear. Click this button to display a Choose Data Source 
dialog box where you can perform a search for the data source. See below for more 
information on the Choose Data Source dialog box. 
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Note: The default data source displayed will be the last one selected from the Choose 
Data Source dialog box. 

3. From the Type list box, select the type of extension (for example, station or cell phone). 

4. Leave the Expires On? column blank when adding a new user. 

5. Do not select the Import from File check box unless you will be using the Directory Import 
utility. 

6. If you do not want the user's actual extension to appear in reports, in the Report As column, 
enter a reporting extension for the current user. It could be the actual extension, the last four 
digits of a credit card number, or a portion of a cell phone number. 

If you need to add another extension for this user, click the Add New button. 

If the user has a reporting extension, then that will be displayed instead of the user's raw extension.  

Deleting an Extension 

To delete an extension, enter an expiration date in the Expires On? text box. The extension will 
become inactive after that date. The nightly purge will delete the extension once there are no more 
calls associated with the extension. 

To delete an extension, perform the following: 

 Enter a date in the Expires On? text box for the extension you want to delete. 

-or- 

 Click the Delete button in the row of the extension you want to delete, and the current date 
is entered in the Expires On? text box. 

AUTHORIZATION CODES 

An authorization code is alphanumeric and has a limit of 15 characters. 

Note: Once you enter an auth code and click the Add New button, you cannot change that 
auth code. If you need to change it, you must delete that auth code and add a new one. 

Adding an Authorization Code 

Follow these steps to add an authorization code for a user: 

1. In the Auth Code column, enter the code assigned to this user. 

2. Depending on the number of data sources defined during the installation process, one of the 
following will apply for the Data Source column: 

 If the number of data sources is less than the maximum number defined during 
installation, a Data Source list box will be displayed. From this list box, select a data 
source for each object for the current user. 

 If the number of data sources exceeds the maximum number defined during installation, 
then a Look Up button will appear. Click this button to display a Choose Data Source 
dialog box where you can perform a search for the data source. See below for more 
information on the Choose Data Source dialog box. 

Note: The default data source displayed will be the last one selected from the Choose 
Data Source dialog box. 

3. In the Expires on? column indicate when the code will become active or inactive. 
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If you need to add another authorization code for this user, click the Add New button. 

Deleting an Authorization Code 

To delete an authorization code, enter an expiration date in the Expires On? text box. The 
authorization code will become inactive after that date. The nightly purge will delete the authorization 
code once there are no more calls associated with the authorization code. 

To delete an authorization code, perform the following: 

 Enter a date in the Expires On? text box for the authorization code you want to delete. 

-or- 

 Click the Delete button in the row of the authorization code you want to delete, and the 
current date is entered in the Expires On? text box. 

TRUNK FACILITIES 

Assigning a trunk facility to a user allows trunk-to-trunk calls to be assigned to a user. 

Adding a Trunk Facility 

Follow these steps to add a trunk facility for a user: 

1. Depending on the number of data sources defined during the installation process, one of the 
following will apply for the Data Source column: 

 If the number of data sources is less than the maximum number defined during 
installation, a Data Source list box will be displayed. From this list box, select a data 
source for each object for the current user. 

 If the number of data sources exceeds the maximum number defined during installation, 
then a Look Up button will appear. Click this button to display a Choose Data Source 
dialog box where you can perform a search for the data source. See below for more 
information on the Choose Data Source dialog box. 

Note: The default data source displayed will be the last one selected from the Choose 
Data Source dialog box. 

2. In the Facility column, select the facility for this user from the list box. The facilities listed 
are those that belong to the Data Source selected from the Data Source column. 

If you need to add another data source/facility combination for this user, click the Add New button. 

Deleting a Trunk Facility 

To delete a facility, click the Delete button in the row of the facility to be removed. 

Charges Tab 

Note for the optional Facilities Management module: 

A warehouse cannot have any fixed or one-time charges attached to it. 

The Charges tab lets you add one-time or fixed charges or credits for the use of special equipment or 
features to a specific user, or to all users within a department. A credit is expressed as a negative 
number -5.00. Fixed Charges appear in Tenant Billing and Cost Summary reports. 
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FIXED CHARGES 

Adding Fixed Charges to a User 

Once a fixed charge has been added to the Fixed Charges Pool, it can be added to a user.  

To add a charge, follow these steps: 

1. Click the Add New button, and a Select Fixed Charges screen displaying all the charges 
and associated codes will appear. 

2. In the Quantity cell, specify how many units of the charge to apply to the person.  

3. Next, you may accept the default Active on? date, or enter a new one. Enter the date in one 
of these formats:  mmddyyyy, mm/dd/yyyy, or mm-dd-yyyy. 

4. Click the Apply button to apply the charge, and you will return to the Charges tab. Assign 
an expiration date to each charge in the Expires On? cell. 

5. If you need to add an additional charge, click the Add New button, and a new row will 
appear in the Fixed Charges table. 

6. Click the Save button to save the change. 

Removing Fixed Charges From a User 

Enter a date in the Expires On? text box for the fixed charge you want to remove from a user. This 
will stop the charge from accruing. Enter the date in one of these formats: 

 mmddyyyy 

 mm/dd/yyyy 

 mm-dd-yyyy 

Adding Fixed Charges to an Entire Department 

Once a fixed charge has been added to the Fixed Charges Pool, it can be added to all the users in a 
department.  

To add a charge to all the users in a department, follow these steps: 

1. At the main Directory Database screen, select the department you want to add equipment 
to by clicking on the symbol in the right hand pane. 

2. Click the  button, or from the Edit menu select the Edit menu item, and the Edit 
Department screen will appear. 

3. At the bottom of the screen, is a table displaying Fixed Charges information for the selected 
department. 

4. Below the table, click the Allocate a fixed charge to all Department members button, 
and a Select Fixed Charges screen displaying all the charges and associated codes appears. 

5. In the Quantity cell, specify how many units of the charge to apply to the department. 

6. Next, you may accept the default Active on? date, or enter a new one. Enter the date in one 
of these formats:  mmddyyyy, mm/dd/yyyy, or mm-dd-yyyy. 

Active on? determines if a charge is pro-rated. Leaving it blank indicates that the charge will 
not be pro-rated. For example, a $10.00 charge is set to occur on the 30th of the month. If 
the Active on? date is blank, the person is charged $10.00 on the 30th of every month after 
the charge was added. If the Active on? date is entered as the 15th of the month, then the 
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charge is pro-rated the first month ($5.00) and is $10.00 per month after that. 

7. Click the Apply button to apply the charge, and you will return to the Edit Department 
screen. 

8. If you need to add an additional charge, click the Allocate a fixed charge to all 
Department members button, and a new row will appear in the Fixed Charges table. 

9. Click the Save button to save the change. 

ONE TIME CHARGES 

Adding One Time Charges to a User 

One Time charges can be entered manually, or selected from the One Time Charges Pool. 

Entering a Charge Manually 

1. If there is not a blank row in the One Time Charges table, click the Add New button. 

2. In the Code field, enter a code for the charge. There is a limit of 20 alphanumeric characters. 
This is optional. 

3. In the Desc. field, enter a description for the charge. There is a limit of 20 alphanumeric 
characters. This is a required field. 

4. In the Quantity field, specify how many units of the charge to apply to the person. This is a 
required field. 

5. In the Unit Charge field, specify how much the charge costs per item. This is required. The 
Ext. Charge field will automatically fill in with the unit charge multiplied by the quantity. 

6. Enter an optional comment in the Comment field. There is a limit of 15 alphanumeric 
characters. 

7. In the Charge Date field, enter the date that the one time charge takes effect. The date 
must be entered in one of the following formats: mmddyyyy, mm/dd/yyyy, or mm-dd-yyyy. 
This is a required field. 

8. If you need to add an additional charge, click the Add New button, and a new row will 
appear in the One Time Charges table. 

Selecting a Charge From The One Time Charges Pool 

1. Click the Add from List button, and a Select One Time Charges screen will appear. 

2. In the Quantity cell for a charge, specify how many units of the charge to apply to the 
person. 

3. Enter an optional comment in the Comment field. There is a limit of 15 alphanumeric 
characters. 

4. In the Charge Date field, enter the date that the one time charge takes effect. The date 
must be entered in one of the following formats: mmddyyyy, mm/dd/yyyy, or mm-dd-yyyy. 
This is a required field. 

5. Click the Apply button to apply the charge, and you will return to the Charges tab. 

Removing One Time Charges From a User 

Click the Delete button that is next to the one time charge you want to delete from the user. 

INVENTORY TABLE 

The Inventory table details the inventory assigned to the current person's record. The information in 
this table cannot be edited. 
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Note: The Inventory table appears only if the optional Facilities Management module was 
purchased. 

Other Numbers Tab 

Note for the optional Facilities Management module: 

If you purchased the optional Facilities Management module and clicked the Flag This 
Person as an Inventory Warehouse check box located in the General Information section, 
you can have phone numbers assigned at this tab to the warehouse. 

The Other Numbers tab stores a directory of home, car, fax, pager, DID (direct inward dialing), and 
other numbers for a person. Enter each number in the appropriate text box. 

Note: The numbers entered at this tab are for reference only and do not appear in any 
reports. 

Billing Address Tab 

The Billing Address tab lets you add a name and address for this person that will appear in a Tenant 
Billing report. Enter the information in the appropriate text boxes. 

Note for the optional Facilities Management module: 

If you purchased the optional Facilities Management module and clicked the Flag This 
Person as an Inventory Warehouse check box located in the General Information section, 
you can have a billing address assigned at this tab to the warehouse. 

ADDING A USER THROUGH SERVICE REQUESTS 

Note: This section applies only if you purchased the optional Facilities Management module. 

When a new person is added from a service request in Facilities Management, that person's record is 
marked as such. The Directory Administrator can then access a listing from the Directory database 
and complete/edit that person's record there. 

To access this listing, perform the following: 

 From the File menu select People Added Through Service Requests. 
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ADDING A RANGE OF EXTENSIONS 

The Add Extension Range menu item lets you enter the entire range of extensions you need for a 
level. For example, if you need to add 25 people in Sales, you can add extensions 1-25 in one step. 

If this is your initial setup, or if you need to add a range of extensions, follow these steps: 

1. In the Directory database screen, expand the level you want to add a person to until the  
symbol appears. Click on the  symbol. 

2. From the Edit menu, or by right clicking in the screen to display the pop-up menu, select 
Add  Add Extension Range, and the Add Item Range dialog box will appear. 

3. Enter the first extension number in the Start text box. 

4. Enter the last extension number in the End text box. 

5. Assign the entire range of extensions to a billing class with the Billing Class list box. 

Note: If you purchased the optional Hospitality module, the Billing Class list box will 
not appear. Instead, there will be a Billing Description list box. Use this list box to 
assign a billing description to the entire range. 

6. With the Data Source list box, assign the entire range of extensions to a data source. If the 
number of data sources exceeds the maximum number defined at the Misc. System 
Options 1 screen during installation, then a Find Word(s) text box and Word Search 
button will appear. There, perform a search for the data source, and the results will appear in 
the Data Source list box. Enter your search string in the Find Word(s) text box. You don't 
have to enter an entire word, just a fragment. After entering a search string, Click the Word 
Search button, and the search results will include all values containing your search string. 

For example, if you enter a search string of "at", your results will include the following: 
cathode, flat screen, gateway. 

Note: The Find Words text box and Word Search button will appear only if the 
number of home sites exceeds the maximum number defined at the Misc. System 
Options 1 screen during installation. 

7. Click OK, and the extensions will appear in the Directory tree. You can now add data for each 
person. Please refer to the section below for information on adding data for each user. 

EDITING THE DIRECTORY DATABASE 

Editing an Organization Level 

To edit an organization level, follow these steps: 

1. At the main Directory Database screen, expand the organization tree, and highlight the 
level you want to edit. 

2. Click the  button, or select Edit from the Edit menu. 

3. An Editing “level” screen for the selected level will appear. 

4. Make the changes, and click the Save & Close button to apply the changes, or the Cancel 
button to close the screen without applying the changes. 
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Editing a User 

Note for the optional Facilities Management module: 

If you purchased the optional Facilities Management module and if you clicked the Flag This 
Person as an Inventory Warehouse check box located on the General tab, this check 
box cannot be turned off if there is inventory in the warehouse.  

To edit a user, follow these steps: 

1. At the main Directory Database screen, expand the organization tree until the department 
containing the user you want to edit is displayed. 

2. Select the department by clicking on the  symbol, and the records of all the users in that 
department will appear in the right pane of the main Directory Database screen. 

3. Click the Edit button next to the user whose record you want to edit. 

4. An Edit screen containing that user's information will appear. This screen is similar to the one 
used for adding a user. 

5. Click one of the tabs at the top of the screen to move to that section, and perform the edit. 

DELETING FROM THE DIRECTORY DATABASE 

Note: Only those with Administrative access can delete organization levels and users. 

Deleting an Organization Level 

An organization level cannot be deleted if there are users below it. All users must be deleted, 
deactivated, and purged before the level can be deleted. 

To delete an organization level, follow these steps: 

1. At the main Directory Database screen, highlight the level to be deleted. 

2. From the Edit menu, select Delete Organization, or click the Delete button . 

Note: All levels subordinate to a deleted level will be deleted! 

Deleting a User 

Notes on the Facilities Management module: 

 Normally, when a person is inactivated, their extension(s) and fixed charge(s) will be 
purged according to the purge parameters defined. With Facilities Management however, if 
a person is inactivated that still has fixed charges assigned to their record, a message will 
appear informing you to contact the inventory manager to have the items returned to the 
warehouse thus removing them from the person's record. 

 If you clicked the Flag This Person as an Inventory Warehouse check box located in 
the General tab, the warehouse cannot be deleted if there is inventory in the warehouse. 

When deleting a user, that user is not removed from the database. A user can only be completely 
removed from the system by inactivating the user, purging all CDR associated with that user, and 
then purging all inactive users with no CDR assigned to them. 

Choosing to delete a user marks them as inactive. When you delete (inactivate) a user, all of their 
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objects (extensions, cell phone numbers, etc.) and fixed charges are also inactivated. The user will 
remain in the database until there are no more calls or fixed charge transactions in the database for 
that user. This way, you can include the user in reports until their data is gone. The nightly purge 
deletes all call records and fixed charge transactions older than the date set. The system will then 
remove all of the inactive users who no longer have call record data or fixed charge transactions from 
the Directory database. 

Further, once a user’s status is changed to inactive, calls are no longer assigned to that user. 

To delete a user, follow these steps: 

1. In the left pane of the main Directory Database screen, highlight the level containing the 
user you want to delete. 

2. In the right pane of the Directory Database main screen, select the check box next to the 
user or users you want to delete. 

3. From the Edit menu, select Delete User, or click the Delete User button . 

4. Click OK at the message box. 

5. If you are deleting more than one user, click Yes to delete each selection individually, or click 
Yes to All to delete all your choices at the same time. 

MOVING A USER 

The Move function lets you move one or more users to a different organization level. To move a user 
or users, follow these steps: 

1. At the main Directory Database screen, expand the organization tree until the  symbol 
containing the user(s) you want to move is displayed. 

2. Select the  symbol, and the users in that level will appear in the right pane of the main 
Directory screen. Select the check box next to each user you want to move. 

3. Click the  button, or select Move Users from the Edit menu. A Move screen will appear. 
This screen is used to specify where you want the user(s) moved. 

4. At the top of the Move screen is a Move Selected Users to: list box and text box. These are 
used to search for the organization level you want to move the user(s) to. 

5. With the list box, specify if you want to search by the organization level name or code. 

6. In the text box, type the organization level name or code. 

7. Click the Search button, and your results will be displayed in a table. The results will display 
the lowest organization levels because this is where the users' records are located. 

8. Next to each search result displayed in the table, a Move button will appear. Click the Move 
button that is next to the organization level you want the user(s) moved to. 

Note: Once a user is moved, they become inactive in their old location and active in their 
new location. 
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SEARCHING THE DIRECTORY DATABASE 

The Search function is used to quickly find a user or organizational level. You can search by data 
source, user's first or last name, organization name, organization code, title, extension, authorization 
code, fixed/one time charge code, or any combination of these. 

Note: It is important to remember that all of the search specifications entered in the text 
boxes are cumulative. This means that the more search criteria you specify, the more 
specific the search will become. 

The search function is accessed from the Edit menu, or by clicking the  button. After selecting it, a 
Search screen will appear. 

Note:  those with View access cannot search on authorization code, title, or charge codes. 

To search the Directory database, follow these steps: 

1. Using the filter grid, define the search criteria for any or all of the field names. When a row is 
double clicked, a dialog box appears that lets you define an operator and search criteria 
specific to the field name in that row. 

Note: It is important to remember that all of the search criteria specified are cumulative. 
This means that the more search criteria you specify, the more specific the search will 
become. 

2. Using the Sort Order list boxes, specify how you want the results sorted by selecting a field 
name from each list box. The defaults are Organizational Name for 1st Sort, Last Name 
for 2nd Sort and none for 3rd Sort. 

3. Click the Find button, and your results will be displayed in the Search Results table. 
Depending on the field names searched, the results displayed will vary. 

4. Double-click on a row or after selecting a row, click the Go to button, and you will be taken 
to that level in the Directory Database main screen. 

5. Use the list boxes on the far right of the screen to sort the search results. 

Note: Exceptions based on security level: 

 If you are searching for a user, after clicking the Go to button, an Edit screen will display for 
that user. Only those with Administrator and User privileges are able to access this screen.  

 For those with View access, the main Directory Database screen will display the expanded 
organization level to which the user searched for is located in, but not the user's Edit screen. 



Quick Reference Guide: Directory Database ISI Telemanagement Solutions, Inc. 

Part Number – 905-011019 14 Infortel Select for the Web Version – 7.5 

DIRECTORY SECURITY SCREEN 

The Directory Security screen is used to control: 

 Who can enter the system 

 Which components of the system a user can access 

 Which organizational levels a user can access (By default a user can access only themselves.) 

 Which data sources a user can access 

At the top of the screen is a set of buttons and a text box that let an administrator designate an ID for 
a user. In the lower part of the screen are three tabs that let an administrator grant access to various 
system functions as well as organizational levels and data sources. Please refer to the table below for 
more information on these tabs. 

Tab Explanation 

Module Access With this tab, a System Administrator or users with Directory 
Administrator privileges can assign access to system modules. A user 
cannot assign access to a module that they themselves cannot access. 

Note for the optional Facilities Management module: 

Using the Module Access tab, you can designate a user as a 
technician, as well as specify the user's Facilities Management access 
level.  

Organizational Access With this tab, a System Administrator or a user with Directory 
Administrator access privileges can specify the organization levels a 
user can access. The top half of the screen is for performing a search 
and displaying the results, and the bottom half (Security and/or Auto 
Mail Access List) displays the organizational levels and people the user 
you are editing will have access to.  

Data Source Access With this tab System Administrator or users with Directory 
Administrator privileges specify which data sources the user can 
access. 

Summary Gates Access With this tab, a System Administrator or users with Directory 
Administrative privileges assign the summary gates the current user 
can display in the Control Center. 

Note: The Summary Gates tab appears only when the 
Dashboard option is purchased. 

 



ISI Telemanagement Solutions, Inc. Quick Reference Guide: Directory Database 

Infortel Select for the Web Version – 7.5  15  Part Number – 905-011019 

OPTION MENU UTILITIES 
Filter Tree View 
The Filter Tree View menu item lets you display all extensions, active extensions, or inactive 
extensions for a specific home site or all home sites. In addition, you can opt to have organization 
levels with no people assigned to them to not be displayed in the organization tree. 

Note: A caption indicating that one or more filter is turned on will appear next to the button 
bar on the Directory Database screen. 

To use this menu item, follow these steps: 

1. From the Options menu, select Filter Tree View, and a Select Filter screen will appear. 

2. From the Extensions/Auth. Codes list box, select which type of extension (active, inactive, 
or all) to display in the organization tree. 

3. From the Home Site list box, select a home site (or all home sites) to display in the 
organization tree. If the number of data sources exceeds the maximum number defined at 
the Misc. System Options 1 screen during installation, then a Find Word(s) text box and 
Word Search button will appear. There, perform a search for the data source, and the 
results will appear in the Home Site list box. Enter your search string in the Find Word(s) 
text box. You don't have to enter an entire word, just a fragment. After entering a search 
string, click the Word Search button, and the search results will include all values containing 
your search string. 

For example, if you enter a search string of "at", your results will include the following: 
cathode, flat screen, gateway. 

Note: The Home Site Search text box and Word Search button will appear only if the 
number of home sites exceeds the maximum number defined at the Misc. System 
Options 1 screen during installation. 

4. If you want to have organization levels with no people assigned to them to not be displayed 
in the organization tree, select the check box. 

5. Click the Reload button to have your selections take effect, or click Cancel to close the 
Select Filter screen. 

6. If you click Reload, the choices selected will be saved for the user that made them. 

Note: The two list boxes can be used in combination with each other. For example, you can 
choose to only have inactive extensions from a specified home site be displayed in the 
organization tree. 

Displaying Active and Inactive Persons 

To display persons with active, inactive, or all extensions in the main Directory Database screen, 
follow these steps: 

1. From the main Directory Database screen, select the Options menu. 

2. Select the Filter Tree View menu item. 

3. At the Select Filter dialog box, select how to filter the directory from the list boxes. 

 From the Extensions list box, select All to display users with both active and inactive 
extensions, Active to display people with just active extensions, or Inactive to display 
people with inactive extensions. 

 From the Site list box, select All to display all sites, or select a specific site. 

4. Click the Reload button. 
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PURGE INACTIVE OBJECTS 

Clicking on the Purge Inactive Objects menu item opens a screen that lets you delete all inactive 
users, objects (except one time charges), and fixed charges. To purge inactive objects, follow these 
steps: 

1. From the Option menu, select Purge Inactive Objects. 

2. A screen appears that lets you specify which objects to purge. 

3. Click the OK button, and those objects will be removed from the Directory database. 

Note: This function is available only for those with Administrator level access.  
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