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Quick Reference Guide: Directory Database for the Web

You must add the levels of the Directory database in order below the Organization symbol 3.

ADDING AN ORGANIZATION LEVEL TO THE DIRECTORY DATABASE

Adding the highest organization level is the first step in creating the Directory database. Adding the
lower levels (apart from the user level) involves the same steps with the exception being that you
highlight a different organization symbol.

There are two routes to adding an organization level:
» Using the Add menu item in the Edit menu
» Clicking the button
These two methods are slightly different and are explained below.

> After highlighting a level, from the Edit menu, select the Add menu item to add any level
above, or immediately below the selected level. An Add “level” dialog box will appear, and
proceed with Step 1 below.

> After highlighting a level, click the button to add a level immediately below the selected
level. An Add “level” dialog box will appear, and proceed with Step 1 below.

1. At the Add "level” dialog box, enter a unique 30 character alphanumeric level name in the
Name text box.

2. In the Code text box, enter a unique 20 character alphanumeric code for this level.
3. Enter the optional hame and address information that will appear in a billing report.

4. Click the Save & Close button.

5. Click the Save & Continue button if you are adding more than one name at this level, and
the dialog box will remain on the screen. When finished, click the Save & Close button to
close the dialog box.

ADDING A USER TO THE DIRECTORY DATABASE
Whenever a user is added to the Directory database, that user is considered “active” until their status
is changed to “inactive.” To add a person, follow these steps:

1. At the main Directory Database screen, expand the level you want to add a person to until
the symbol appears. Click on the symbol.

2. Click the button, or from the Edit menu, choose Add Person from the submenu. With
either method, the Add Person screen will appear.

3. The Add Person screen contains five tabs for adding information on a person, and above the
tabs is a set of buttons.

Move: When you click this button, a screen will appear to let you move the current user to another
organization level. See the section below for information on the Move feature.

Delete: This button deletes the current user from the database. See below for more information on
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deleting a user.
Save: Click this button to save the information while keeping the screen displayed.
Save & Close: Click this button to save the information and close the screen.

Close: Click this button to close the screen without saving any information.

General Tab

The General tab is used for entering basic information for a user as well as indicating if the user will
or will not receive automatically generated reports, specifying a Billing Class for the user, and
assigning the user a security level.

Last Name: Enter the user's last name in this text box. This is a required field.
First Name: Enter the user's first name in this text box. This is optional.
Title: Enter the user's title in this text box. This is optional.

E-mail: Enter the user's e-mail address in this text box. This is optional.

Exclude this person from auto-mail: Select this check box if you do not want this user to
automatically receive reports via e-mail.

Billing Class: Assign the user a Billing Class (default is Billing Class 1) from this list box. This
selection will determine which Billing Descriptions are used to price the user's calls.

Home Site: Select the site where the user is physically located from this list box.

Directory Import Key: The Directory Import Key is used when importing new directory information.
Additionally, it can be used to assign multiple extensions to the same user, support name changes,
and lets you automate moves and deletions. (Optional)

Code: In this text box, enter a unique code that will be used when the user's information is exported
to a time and billing or accounting system. (Optional)

Security Setting: Clicking this button opens the Directory Security screen. The Directory Security
screen is used to control:

» Who can enter the system
» Which components of the system a user can access
» Which data sources a user can access
See below for more information on the Directory Security Screen.

Room number: Type a valid room number in this text box. This text box appears only if you
purchased the optional Lodging module.

Objects Tab

Using the Objects tab, extensions, authorization codes, and trunk facilities (these types of data are
referred to as “objects”), are added, maintained, and displayed in a table for each user.

It is important to keep in mind that an extension can be:
» An actual extension
» A credit card number or a portion of a credit card number

> A cell phone number
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EXTENSIONS

An extension can be the actual extension, a credit card number, or a cell phone number assigned to a
user.

If the user has a reporting extension, then that will be displayed instead of the user's raw extension.

» A reporting extension is an extension that shows up in a report. It could be the actual
extension, the last four digits of a credit card number, or a portion of a cell phone number.

> A raw extension is an extension as it comes in from the CDR.

Note: Once you enter an extension and click the Add New button, you cannot change that
extension. If you need to change it, you must delete that extension and add a new one.

Adding an Extension
Follow these steps to add an extension for a user:
1. In the Extension column, enter the extension as it appears in the CDR.
From the Data Source list box, select the data source of the extension.
From the Type list box, select the type of extension (for example, station or cell phone).

Leave the Expires On? column blank when adding a new user.

au »h W N

Do not select the Import from File check box unless you will be using the Directory Import
utility.

6. If you do not want the user's actual extension to appear in reports, in the Report As column,
enter a reporting extension for the current user. It could be the actual extension, the last four
digits of a credit card number, or a portion of a cell phone number.

If you need to add another extension for this user, click the Add New button.

If the user has a reporting extension, then that will be displayed instead of the user's raw extension.
Deleting an Extension

To delete an extension, enter an expiration date in the Expires On? text box. The extension will
become inactive after that date. The nightly purge will delete the extension once there are no more
calls associated with the extension.

To delete an extension, perform the following:
> Enter a date in the Expires On? text box for the extension you want to delete.
_or-

» Click the Delete button in the row of the extension you want to delete, and the current date
is entered in the Expires On? text box.

AUTHORIZATION CODES

An authorization code is alphanumeric and has a limit of 15 characters.

Note: Once you enter an auth code and click the Add New button, you cannot change that
auth code. If you need to change it, you must delete that auth code and add a new one.

Adding an Authorization Code

Follow these steps to add an authorization code for a user:
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1. In the Auth Code column, enter the code assigned to this user.
2. In the Data Source column, select the data source for this user from the list box.
3. In the Expires on? column indicate when the code will become active or inactive.

If you need to add another authorization code for this user, click the Add New button.
Deleting an Authorization Code

To delete an authorization code, enter an expiration date in the Expires On? text box. The
authorization code will become inactive after that date. The nightly purge will delete the authorization
code once there are no more calls associated with the authorization code.

To delete an authorization code, perform the following:
> Enter a date in the Expires On? text box for the authorization code you want to delete.
—or—

» Click the Delete button in the row of the authorization code you want to delete, and the
current date is entered in the Expires On? text box.

TRUNK FACILITIES

Assigning a trunk facility to a user allows trunk-to-trunk calls to be assigned to a user.
Adding a Trunk Facility

Follow these steps to add a trunk facility for a user:
1. In the Data Source column, select the data source for this user from the list box.

2. In the Facility column, select the facility for this user from the list box. The facilities listed are
those that belong to the Data Source selected from the Data Source column.

If you need to add another data source/facility combination for this user, click the Add New button.
Deleting a Trunk Facility

To delete a facility, click the Delete button in the row of the facility to be removed.

Charges Tab

The Charges tab lets you add one-time or fixed charges or credits for the use of special equipment or
features to a specific user, or to all users within a department. A credit is expressed as a negative
number -5.00. Fixed Charges appear in Tenant Billing and Cost Summary reports.

FIXep CHARGES
Adding Fixed Charges to a User

Once a fixed charge has been add to the Fixed Charges Pool, it can be added to a user.
To add a charge, follow these steps:

1. Click the Add New button, and a Select Fixed Charges screen displaying all the charges
and associated codes will appear.

2. In the Quantity cell, specify how many units of the charge to apply to the person.

3. Next, you may accept the default Active on? date, or enter a new one. Enter the date in one
of these formats: mmddyyyy, mm/dd/yyyy, or mm-dd-yyyy.
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4. Click the Apply button to apply the charge, and you will return to the Charges tab. Assign
an expiration date to each charge in the Expires On? cell.

5. If you need to add an additional charge, click the Add New button, and a new row will
appear in the Fixed Charges table.

6. Click the Save button to save the change.
Removing Fixed Charges From a User

Enter a date in the Expires On? text box for the fixed charge you want to remove from a user. This
will stop the charge from accruing. Enter the date in one of these formats:

>  mmddyyyy
> mm/dd/yyyy
» mm-dd-yyyy

Adding Fixed Charges to an Entire Department

Once a fixed charge has been add to the Fixed Charges Pool, it can be added to all the users in a
department.

To add a charge to all the users in a department, follow these steps:

1. At the main Directory Database screen, select the department you want to add equipment
to by clicking on the symbol in the right hand pane.

2. Click the button, or from the Edit menu select the Edit menu item, and the Edit
Department screen will appear.

3. At the bottom of the screen, is a table displaying Fixed Charges information for the selected
department.

4. Below the table, click the Allocate a fixed charge to all Department members button,
and a Select Fixed Charges screen displaying all the charges and associated codes appears.

5. In the Quantity cell, specify how many units of the charge to apply to the department.

6. Next, you may accept the default Active on? date, or enter a new one. Enter the date in one
of these formats: mmddyyyy, mm/dd/yyyy, or mm-dd-yyyy.

Active on? determines if a charge is pro-rated. Leaving it blank indicates that the charge will
not be pro-rated. For example, a $10.00 charge is set to occur on the 30" of the month. If
the Active on? date is blank, the person is charged $10.00 on the 30 of every month after
the charge was added. If the Active on? date is entered as the 15™ of the month, then the
charge is pro-rated the first month ($5.00) and is $10.00 per month after that.

7. Click the Apply button to apply the charge, and you will return to the Edit Department
screen.

8. If you need to add an additional charge, click the Allocate a fixed charge to all
Department members button, and a new row will appear in the Fixed Charges table.

9. Click the Save button to save the change.
ONE TIME CHARGES
Adding One Time Charges to a User
One Time charges can be entered manually, or selected from the One Time Charges Pool.

» To enter a charge manually, follow these steps:
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1. If there is not a blank row in the One Time Charges table, click the Add New button.

2. In the Code field, enter a code for the charge. There is a limit of 20 alphanumeric characters.
This is optional.

3. In the Desc. field, enter a description for the charge. There is a limit of 20 alphanumeric
characters. This is a required field.

4. In the Quantity field, specify how many units of the charge to apply to the person. This is a
required field.

5. In the Unit Charge field, specify how much the charge costs per item. This is required. The
Ext. Charge field will automatically fill in with the unit charge multiplied by the quantity.

6. Enter an optional comment in the Comment field. There is a limit of 15 alphanumeric
characters.

7. In the Charge Date field, enter the date that the one time charge takes effect. The date
must be entered in one of the following formats: mmddyyyy, mm/dd/yyyy, or mm-dd-yyyy.
This is a required field.

8. If you need to add an additional charge, click the Add New button, and a new row will
appear in the One Time Charges table.

» To select a charge from the One Time Charges Pool, follow these steps:
1. Click the Add from List button, and a Select One Time Charges screen will appear.

2. In the Quantity cell for a charge, specify how many units of the charge to apply to the
person.

3. Enter an optional comment in the Comment field. There is a limit of 15 alphanumeric
characters.

4. In the Charge Date field, enter the date that the one time charge takes effect. The date
must be entered in one of the following formats: mmddyyyy, mm/dd/yyyy, or mm-dd-yyyy.
This is a required field.

5. Click the Apply button to apply the charge, and you will return to the Charges tab.
Removing One Time Charges From a User

Click the Delete button that is next to the one time charge you want to delete from the user.

Other Numbers Tab

The Other Numbers tab stores a directory of home, car, fax, pager, DID (direct inward dialing), and
other numbers for a person. Enter each number in the appropriate text box.

Note: The numbers entered at this tab are for reference only and do not appear in any
reports.

Billing Address Tab

The Billing Address tab lets you add a name and address for this person that will appear in a Tenant
Billing report. Enter the information in the appropriate text boxes.

EDITING THE DIRECTORY DATABASE

Editing an Organization Level
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To edit an organization level, follow these steps:

1. At the main Directory Database screen, expand the organization tree, and highlight the
level you want to edit.

2. Click the button, or select Edit from the Edit menu.
3. An Editing “level” screen for the selected level will appear.

4. Make the changes, and click the Save & Close button to apply the changes, or the Cancel
button to close the screen without applying the changes.

Editing a User

To edit a user, follow these steps:

1. At the main Directory Database screen, expand the organization tree until the department
containing the user you want to edit is displayed.

2. Select the department by clicking on the symbol, and the records of all the users in that
department will appear in the right pane of the main Directory Database screen.

3. Click the Edit button next to the user whose record you want to edit.

4. An Edit screen containing that user's information will appear. This screen is similar to the one
used for adding a user.

5. Click one of the tabs at the top of the screen to move to that section, and perform the edit.

DELETING FROM THE DIRECTORY DATABASE

|| Note: Only those with Administrative access can delete organization levels and users. ||

Deleting an Organization Level

An organization level cannot be deleted if there are users below it. All users must be deleted,
deactivated, and purged before the level can be deleted.

To delete an organization level, follow these steps:

1. At the main Directory Database screen, highlight the level to be deleted.

2. From the Edit menu, select Delete Organization, or click the Delete button .

|| Note: All levels subordinate to a deleted level will be deleted! ||

Deleting a User

When deleting a user, that user is not removed from the database. A user can only be completely
removed from the system by inactivating the user, purging all CDR associated with that user, and
then purging all inactive users with no CDR assigned to them.

Choosing to delete a user marks them as inactive. When you delete (inactivate) a user, all of their
objects (extensions, cell phone numbers, etc.) and fixed charges are also inactivated. The user will
remain in the database until there are no more calls or fixed charge transactions in the database for
that user. This way, you can include the user in reports until their data is gone. The nightly purge
deletes all call records and fixed charge transactions older than the date set. The system will then
remove all of the inactive users who no longer have call record data or fixed charge transactions from
the Directory database.
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Further, once a user’s status is changed to inactive, calls are no longer assigned to that user.

To delete a user, follow these steps:

1. In the left pane of the main Directory Database screen, highlight the level containing the
user you want to delete.

2. In the right pane of the Directory Database main screen, select the check box next to the
user or users you want to delete.

3. From the Edit menu, select Delete User, or click the Delete User button .

4. Click OK at the message box.

5. If you are deleting more than one user, click Yes to delete each selection individually, or click
Yes to All to delete all your choices at the same time.

MOVING A USER

The Move function lets you move one or more users to a different organization level. To move a user
or users, follow these steps:

1.

At the main Directory Database screen, expand the organization tree until the symbol
containing the user(s) you want to move is displayed.

Select the symbol, and the users in that level will appear in the right pane of the main
Directory screen. Select the check box next to each user you want to move.

Click the button, or select Move Users from the Edit menu. A Move screen will appear.
This screen is used to specify where you want the user(s) moved.

At the top of the Move screen is a Move Selected Users to: list box and text box. These are
used to search for the organization level you want to move the user(s) to.

With the list box, specify if you want to search by the organization level name or code.
In the text box, type the organization level nhame or code.

Click the Search button, and your results will be displayed in a table. The results will display
the lowest organization levels because this is where the users' records are located.

Next to each search result displayed in the table, a Move button will appear. Click the Move
button that is next to the organization level you want the user(s) moved to.

Note: Once a user is moved, they become inactive in their old location and active in their
new location.

SEARCHING THE DIRECTORY DATABASE

The Search function is used to quickly find a user or organizational level. You can search by data
source, user's first or last name, organization name, organization code, title, extension, authorization
code, fixed/one time charge code, or any combination of these.

Note: It is important to remember that all of the search specifications entered in the text
boxes are cumulative. This means that the more search criteria you specify, the more
specific the search will become.

Next to data source, last and first name, organization name and code, and title are text boxes that let
you determine how the search results will be sorted. Enter a number next to the search fields to
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indicate the order in which you want them to sort.

|| Note: those with View access cannot search on authorization code, title, or charge codes. ||

The search function is accessed from the Edit menu, or by clicking the button. After selecting it, a
Search screen will appear. To search the Directory database, follow these steps:

1. From the Data Source list box, select the data source.

2. Enter the search criteria in any or all of the text boxes. You may enter the first few characters
of the value, as well.

3. In the Sort Order text boxes, specify how you want the your results sorted by entering a
number in the adjoining field's Sort Order text box. The defaults are Organizational Name of
1 and Last Name of 2.

4. Click the Search button, and your results will be displayed in a Search Results table.
Depending on the type of data searched (e.g., organization name, user name, authorization
code, etc.), the results displayed will vary.

5. In the Name column of the Search Results table, place your cursor over the name, and it
becomes highlighted. Click on the name, and that user's information will appear for editing.

|| Note: Exceptions based on security level: ||

» If you are searching for a user, after clicking the Go to button, an Edit screen will display for
that user. Only those with Administrator and User privileges are able to access this screen.

> For those with View access, the main Directory Database screen will display the expanded
organization level to which the user searched for is located in, but not the user's Edit screen.

DIRECTORY SECURITY SCREEN

The Directory Security screen is used to control:
» Who can enter the system
» Which components of the system a user can access
» Which organizational levels a user can access (By default a user can access only themselves.)
» Which data sources a user can access

At the top of the screen is a set of buttons and a text box that let an administrator designate an ID for
a user. In the lower part of the screen are three tabs that let an administrator grant access to various
system functions as well as organizational levels and data sources. Please refer to the table below for

more information on these tabs.

Tab Explanation

Module Access With this tab, a System Administrator or users with Directory
Administrator privileges can assign access to system modules. A user
cannot assign access to a module that they themselves cannot access.

Organizational Access With this tab, a System Administrator or a user with Directory
Administrator access privileges can specify the organization levels a
user can access. The top half of the screen is for performing a search
and displaying the results, and the bottom half (Security and/or Auto
Mail Access List) displays the organizational levels and people the user
you are editing will have access to.
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Data Source Access With this tab System Administrator or users with Directory
Administrator privileges specify which data sources the user can
access.

OPTION MENU UTILITIES

Filter Tree View

The Filter Tree View menu item lets you display all extensions, active extensions, or inactive
extensions for a specific home site or all home sites. In addition, you can opt to have organization
levels with no people assigned to them to not be displayed in the organization tree. To use this menu
item, follow these steps:

1.
2.

6.

From the Options menu, select Filter Tree View, and a Select Filter screen will appear.

From the Extensions/Auth. Codes list box, select which type of extension (active, inactive,
or all) to display in the organization tree.

From the Home Sites list box, select a home site (or all home sites) to be displayed.

If you want to have organization levels with no people assigned to them to not be displayed
in the organization tree, select the check box.

Click the Reload button to have your selections take effect, or click Cancel to close the
Select Filter screen.

If you click Reload, the choices selected will be saved for the user that made them.

Note: The two list boxes can be used in combination with each other. For example, you can
choose to only have inactive extensions from a specified home site be displayed in the
organization tree.

Displaying Active and Inactive Persons

To display persons with active, inactive, or all extensions in the main Directory Database screen,
follow these steps:

1. From the main Directory Database screen, select the Options menu.
2. Select the Filter Tree View menu item.
3. At the Select Filter dialog box, select how to filter the directory from the list boxes.
® From the Extensions list box, select All to display users with both active and inactive
extensions, Active to display people with just active extensions, or Inactive to display
people with inactive extensions.
e From the Site list box, select All to display all sites, or select a specific site.
4. Click the Reload button.
PURGE INACTIVE OBJECTS

Clicking on the Purge Inactive Objects menu item opens a screen that lets you delete all inactive
users, objects (except one time charges), and fixed charges. To purge inactive objects, follow these

steps:
1.

2.
3.

From the Option menu, select Purge Inactive Objects.
A screen appears that lets you specify which objects to purge.

Click the OK button, and those objects will be removed from the Directory database.

|| Note: This function is available only for those with Administrator level access. ||
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